Customineを使ったカスタマイズで、「kintone API呼び出しがエラーになりました」というエラーダイアログが出ることがあります。これを解決するには、kintone側・Customine側いずれかの設定を修正する必要があります。
以下に、代表的エラーメッセージ例とエラーコード、これらのエラーの対応方法をご紹介します。
入力内容が正しくありません。
Code: CB_VA01
record.フィールドコード.value: 必須です
原因
レコードを追加・更新する「やること」を実行した際に、必須入力のフィールドに値がセットされていない。
対応方法
kintone側の設定で「必須項目にする」の指定がされているフィールドは、Customineのカスタマイズで追加・更新する際にも必須のフィールドになります。
「必須チェックを行う」のようなエラーチェックを追加するか、必ず何らかの値が入るようなカスタマイズを作成して下さい。
より詳しい説明はこちらの「「入力内容が正しくありません。records[0].〇〇.value: 必須です」というエラーが出ました。」をご確認ください。
入力内容が正しくありません。
Code: CB_VA01
record.フィールドコード.value: "○○"は選択肢にありません
原因
ドロップダウンにフォーム設定上存在しない値をセットしようとした。
対応方法
kintone側の設定で追加したい値をドロップダウンに追加するか、もしくはこの値を追加しない別の方法を検討して下さい。
ルックアップの参照先から値をコピーできません。「コピー元のフィールド」に指定したフィールドの設定で「値の重複を禁止する」を選択しておく必要があります。
Code: GAIA_LO03
原因
kintone側のルックアップの設定で、「値の重複を禁止する」の設定がされていない。
対応方法
kintone側のルックアップの設定を変更する必要があります。
詳しい説明はこちらの「「ルックアップの参照先から値をコピーできません」というエラーが出ました。」をご確認下さい。
入力内容が正しくありません。
Code: CB_CA01
records[0].フィールドコード.value: 値が他のレコードと重複しています。
原因
レコードを追加・更新する「やること」を実行した際に、エラーメッセージの「フィールドコード」でセットされた値が、他のレコードと重複している。
対応方法
カスタマイズが実行された時に、「キーを指定してレコードを取得する」などを使用して事前に存在を確認するなど、重複した値が入らないようにして下さい。
より詳しい説明はこちらの「「入力内容が正しくありません。records[0].〇〇.value: 値が他のレコードと重複しています。」というエラーが出ました。」をご確認ください。
入力内容が正しくありません。
Code: CB_CA01
records[日時].value: 日時はISO8601形式の必要があります。
原因
レコードを追加・更新する「やること」を実行した際に、日時のフィールドに文字列を入れたり、数値のフィールドに文字列を入れようとしている。
対応方法
Customineのカスタマイズで、日時・日付・時刻および数値フィールドに文字列をセットしているところで、おかしい値がないか、確認して下さい。
日時系のフィールドであれば以下のような書式である必要があります。
日時 : “YYYY-MM-DDTHH:mm:00+09:00”
日付 : “YYYY-MM-DD”
数値であれば、数値が入った文字列フィールドなどを正しく指定して下さい。
Code: CB_VA01
Query: クエリ記法が間違っています。
原因
Customineの「クエリで条件を指定してレコードを取得する」で指定した「検索条件」の記述方法が間違っています。
対応方法
Customineで作成したカスタマイズの、「クエリで条件を指定してレコードを取得する」の「検索条件」を修正する必要があります。より詳しい説明はこちらの「「クエリ記法が間違っています。」というエラーが出ました。」をご確認下さい。
指定したrevisionは最新ではありません。ほかのユーザーがレコードを更新した可能性があります。
Code: GAIA_CO02
原因
レコードを更新する「やること」で、同じレコードに対して2回以上の更新を同時に実行しようとしています。
対応方法
Customineで作成したカスタマイズを修正する必要があります。より詳しい説明はこちらの「「指定したrevisionは最新ではありません。ほかのユーザーがレコードを更新した可能性があります。」というエラーが出ました。」をご確認下さい。
ステータスの変更に失敗しました。他のユーザーがステータス、またはステータスの設定を変更した可能性があります。
Code: GAIA_IL03
原因
kintoneプロセス管理でステータスがA→B→Cと設定されている状態で、
CustomineでA→Cのようにステータスを変更しようとした(kintone上で操作不可能なステータス変更をしようとした)
または、Customineで「ステータス変更アクション」に指定したkintoneのプロセス管理アクションを削除した
対応方法
Customineのカスタマイズを、A→B または B→C のステータス変更に修正してください。
または、kintone側の設定で変更したステータスがkintone上に存在するか確認してください。
ステータスの更新に失敗しました。指定したアクション(完了する)は複数存在するため、実行するアクションを特定できません。
Code: GAIA_SA03
原因
以下のように、kintoneのプロセス管理の設定で、一つのステータスに対して同じ名前のアクションを複数設定したとき(ここでは「完了する」という名前が重複しています)。 設定した時はエラーにならず、そのアクションを実行しようとしたときにエラーになりますのでご注意下さい。
対応方法
kintoneのプロセス管理の設定で、【アクション名(ボタン名)】で重複が起こらないように設定してください。
レコードの絞り込み条件に指定したユーザー、グループ、または組織が存在しません。削除された可能性があります。
Code: GAIA_IL42
原因
一覧画面の一覧設定にユーザーを指定した絞り込みがある状態で、そのユーザーを削除したとします。この状態でも、kintoneアプリは問題なく動作します。
その後Customineで、「一覧画面にキーワードで検索する検索フォームを設置する」を利用すると、こちらのエラーになります。
対応方法
kintoneの設定で、削除したユーザーを絞り込みの条件に利用している一覧は、削除するか別のユーザーを指定して下さい。
権限がありません
Code: CB_NO02
原因
kintoneの設定で、レコード更新時にレコードのアクセス権限で編集権限が無い場合。
対応方法
kintone側のアクセス権の設定で、Customineのカスタマイズでレコードの更新を実行しようとしているユーザーに、レコードのアクセス権限で編集権限があるかどうか、確認して下さい。
「作業者を変更する(現在のレコード)」で「kintone アプリの API トークン」を設定した 以外 の場合は、カスタマイズは必ずkintoneにログインしたユーザー(画面を開いているユーザー)の権限で実行されます。
フィールド「ルックアップ」の値「ルックアップ」が、ルックアップの参照先のフィールドにないか、またはアプリやフィールドの閲覧権限がありません。
Code: GAIA_LO04
原因
kintoneの設定で、カスタマイズを実行しようとしているユーザーに、ルックアップの参照先のアプリまたはフィールドの閲覧権限が無い場合に、このエラーが出ます。
また、Customineの「レコードを更新する」系を利用したカスタマイズで、ルックアップフィールドに参照先に存在しない値を記述した際にも、このエラーが出ます。
対応方法
kintoneの設定で、ルックアップの参照先アプリの閲覧権限を確認して下さい。
まとめ
表示されているエラーメッセージから、原因と対応方法をご紹介しました。 これ以外にもkintoneが表示するエラーメッセージは多数ありますので、メッセージの内容をよく読んで対応していって下さい。
何かわからないことがありましたら、チャットサポートまでご連絡下さい。